Configurações Iniciais do WLC

Publicado: 28 de junho de 2011 em Wireless - WLC
Tags:, , , ,

Pessoal,

Em resposta a uma dúvida do leitor Vagner do Prado, resolvi fazer um post mostrando o step-by-step das configurações iniciais do WLC.

O título deste post é o seguinte: tenho um WLC modelo 4402 e 10 Access Points. E agora?

Neste post irei mostrar a configuração básica de todos os equipamentos necessários para colocar a rede Wireless para funcionar, seguindo as Best Practices.

Inicialmente, vamos supor a seguinte topologia:

Topologia LAB WLC

O WLC-4402 fará o papel de servidor de autenticação (AAA) e o roteador será também o DHCP-Server.

Serão criadas 3 WLANs:

  • WLAN de Dados: SSID wlan-dados, associada à VLAN 10, e pool DHCP 192.168.10.0 /24
  • WLAN de Voz: SSID wlan-voice, associada à VLAN 20, e pool DHCP 192.168.20.0 /24
  • WLAN Guest: SSID wlan-guest, associada à VLAN 30, e pool DHCP 192.168.30.0 /24

O idéia de criar 3 WLANs é segmentar o tráfego de forma que os dados da wlan-dados não impactem a transmissão de dados da wlan-voice, uma vez que tais dados são sensíveis ao delay. Também criaremos uma wlan-guest, com acesso restrito, para os usuários convidados.

Vamos às configurações… Começando pelo router.

  • CONFIGURAÇÃO DO ROUTER

Criação Dos Escopos DHCP

Router# conf t

Router(config)# ip dhcp pool dhcp_gerencia_rede

Router(dhcp-config)# network 192.168.5.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.5.1

Router(dhcp-config)# exit

Router(config)#

Router(config)# ip dhcp pool dhcp_dados

Router(dhcp-config)# network 192.168.10.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.10.1

Router(dhcp-config)# exit

Router(config)#

Router(config)# ip dhcp pool dhcp_voz

Router(dhcp-config)# network 192.168.20.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.20.1

Router(dhcp-config)# exit

Router(config)#

Router(config)# ip dhcp pool dhcp_guest

Router(dhcp-config)# network 192.168.30.0 255.255.255.0

Router(dhcp-config)# default-router 192.168.30.1

Router(dhcp-config)# exit

Router(config)#

Router(config)# ip dhcp excluded-address 192.168.5.1 192.168.5.10

Router(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.10

Router(config)# ip dhcp excluded-address 192.168.20.1 192.168.20.10

Router(config)# ip dhcp excluded-address 192.168.30.1 192.168.30.10

Router(config)#

Configuração Das Subinterfaces

Router(config)# interface FastEthernet0/1.5

Router(config-subif)# encapsulation dot1Q 5

Router(config-subif)# ip address 192.168.5.1 255.255.255.0

Router(config-subif)# exit

Router(config)#

Router(config)# interface FastEthernet0/1.10

Router(config-subif)# encapsulation dot1Q 10

Router(config-subif)# ip address 192.168.10.1 255.255.255.0

Router(config-subif)# exit

Router(config)#

Router(config)# interface FastEthernet0/1.20

Router(config-subif)# encapsulation dot1Q 20

Router(config-subif)# ip address 192.168.20.1 255.255.255.0

Router(config-subif)# exit

Router(config)#

Router(config)# interface FastEthernet0/1.30

Router(config-subif)# encapsulation dot1Q 30

Router(config-subif)# ip address 192.168.30.1 255.255.255.0

Router(config-subif)# exit

Router(config)#

Router(config)# interface FastEthernet0/1

Router(config-if)# no shutdown

Router(config-if)# end

Salvando As Configurações

Router# wr

  • CONFIGURAÇÃO DO SWITCH

Criação Das VLANs

Switch# conf t

Switch(config)# vlan 5

Switch(config-vlan)# name vlan_gerencia_rede

Switch(config-vlan)# vlan 10

Switch(config-vlan)# name vlan_dados

Switch(config-vlan)# vlan 20

Switch(config-vlan)# name vlan_voice

Switch(config-vlan)# vlan 30

Switch(config-vlan)# name vlan_guest

Switch(config-vlan)# exit

Switch(config)#

Configuração Da Interface Conectadas Ao Router:

Switch(config)# interface fa0/1

Switch(config-if)# description Router

Switch(config-if)# switchport trunk encapsulation dot1q

Switch(config-if)# switchport mode trunk

Switch(config-if)# no shutdown

Switch(config-if)# exit

Switch(config)#

Configuração Das Interfaces Conectadas Ao WLC:

Switch(config)# interface range GigabitEthernet 0/1 – 2

Switch(config-if-range)# description WLC

Switch(config-if-range)# switchport mode trunk

Switch(config-if-range)# channel-group 1 mode on

Switch(config-if-range)# no shutdown

Switch(config-if-range)# exit

Switch(config)# port-channel load-balance src-dst-ip

Switch(config)#

 

Configuração Das Interfaces Conectadas Aos Access Points:

Switch(config)#interface range fastEthernet 0/1 – 11

Switch(config-if-range)# description Access Point

Switch(config-if-range)#switchport mode access

Switch(config-if-range)#switchport access vlan 5

Switch(config-if-range)#no shutdown

Switch(config-if-range)#end

Switch#wr

Finalmente, toda a infraestrutura está preparada aguardando o WLC. Vamos conectar uma máquina a interface console do WLC e ligá-lo. Se ele não possuir nenhuma configuração, será exibida a Wizard Configuration Tool, conforme exibido abaixo:

(Cisco Controller)

Welcome to the Cisco Wizard Configuration Tool

Use the ‘-‘ character to backup

Would you like to terminate autoinstall? [yes]:

Sempre que você quiser voltar para uma pergunta tecle “-“ e depois enter.

Hostname do WLC

System Name [Cisco_49:55:c0] (31 characters max): WLC-4402

Dados de acesso (username e password)

Enter Administrative User Name (24 characters max): cisco

Enter Administrative Password (24 characters max): *****

Re-enter Administrative Password                 : *****

Endereço IP da interface de gerenciamento (este é o endereço utilizado para acesso via Web Interface)

Management Interface IP Address: 192.168.5.2

Management Interface Netmask: 255.255.255.0

Management Interface Default Router: 192.168.5.1

Management Interface VLAN Identifier (0 = untagged): 5

DHCP server da Management Interface

Management Interface DHCP Server IP Address: 192.168.5.1

Endereço IP da interface de comunicação com os Access Points

AP Manager Interface IP Address: 192.168.5.3

AP-Manager is on Management subnet, using same values

AP Manager Interface DHCP Server (192.168.5.1):

Endereço da interface virtual (utilizada para Web Authentication)

Virtual Gateway IP Address: 1.1.1.1

Nome dado ao Mobility Group

Mobility/RF Group Name: LAB

Criação de um SSID qualquer

Network Name (SSID): LAB

Configure DHCP Bridging Mode [yes][NO]: NO

Allow Static IP Addresses [YES][no]: YES

Não vamos configurar o Servidor Radius agora

Configure a RADIUS Server now? [YES][no]: no

Warning! The default WLAN security policy requires a RADIUS server.

Please see documentation for more details.

Country Code (para Brasil utilizar BR)

Enter Country Code list (enter ‘help’ for a list of countries) [US]: BR

Enable 802.11b Network [YES][no]: no

Enable 802.11a Network [YES][no]: YES

Permitir que o WLC gerencie as configurações de RF (potencia de transmissão e canal)

Enable Auto-RF [YES][no]: YES

Não vamos configurar um NTP agora

Configure a NTP server now? [YES][no]: no

Configuração do horário (é importante configurar o horário nesta etapa para que os APs consigam se associar ao WLC)

Configure the system time now? [YES][no]: YES

Enter the date in MM/DD/YY format: 06/27/11

Enter the time in HH:MM:SS format: 18:50:30

Configuration correct? If yes, system will save it and reset. [yes][NO]: yes

Configuration saved!

Resetting system with new configuration…

Configuration saved!

Resetting system with new configuration…

Pronto, as configurações iniciais foram realizadas! O WLC irá reiniciar para aplicar as novas configurações e em seguida podemos acessá-lo via Web Interface.

Vamos conectar uma máquina na interface fa0/20 do switch e configurar tal interface na VLAN de gerencia.

Switch(config)#interface fastEthernet 0/20

Switch(config-if)# switchport mode access

Switch(config-if)# switchport access vlan 5

Switch(config-if)# no shutdown

Switch(config-if)#end

Estando o WLC e os Access Points na mesma rede, os APs encontrarão o WLC por Layer 2 Broadcast. Supondo que tais APs são novos e nunca se juntaram a um WLC, eles terão uma imagem instalada chamada recovery image (ela possui rckv no nome). Esta imagem contém apenas o protocolo mínimo para o AP se comunicar com o WLC e baixar a imagem completa.

Via Web Interface, clicando na guia WIRELESS, será possível ver os APs fazendo o download da imagem. Após o download terminar, os APs reiniciarão e, em seguida, se associarão ao WLC novamente.

Verifique se a LAG interface está habilitada, para isso acesse CONTROLLER > General:

LAG Interface

O modo deve estar em Enabled. Alterações no LAG mode requerem que o WLC seja reiniciado.

Inicialmente vamos criar as interfaces dinâmicas e, em seguida, atrelar tais interfaces às respectivas WLANs. Para isso clique na guia CONTROLLER > Interfaces > New. Vamos criar a interface para WLAN de dados:

Interface Dinâmica para WLAN de Dados

Clicar em Apply.

Preencher como na figura abaixo:

Interface para wlan-dados

Repetir o processo para as interfaces voice e guest.

Como o WLC irá fazer o papel de servidor de autenticação (AAA), precisamos configurar um EAP Profile. Neste exemplo usarei EAP-PEAP.

Clique na Guia SECURITY > Local EAP > Profiles > New. De um nome a tal profile, chamarei de LocalEAP-Peap. Check a box PEAP:

Local EAP Profiles

Clique em Apply.

Vamos criar um usuário… SECURITY > AAA > Local Net Users > New.

Usuário Local

Clique em Apply.

Agora vamos criar as WLANs, começando pela wlan-dados. Clique na guia WLANs > Create New > Go.

wlan-dados

Clique em Apply.

Na tela seguinte, marque a checkbox Enabled para habilitar tal WLAN, associe-a à interface de dados e, caso desejar, habilite o broadcast do SSID.

Configuração wlan-dados

A guia Security, já vem com uma configuração adequada para a sub aba Layer 2:

Security Layer 2

Em Layer 3 nada é configurado. E na aba AAA Server, devemos habilitar o Local EAP Authentication e selecionar o Profile criado.

Security AAA Servers

Não iremos alterar as configurações de QoS e Advanced.

A configuração da wlan-voice é similar e, portanto, irei pular esta etapa.

Vamos à configuração da wlan-guest.

A guia General é configurada de forma análoga, observando apenas que temos que atrelar tal WLAN à interface guest.

Em Security > Layer 2, não configuramos nada:

Guest WLAN Security Layer 2

E em Layer 3:

Guest WLAN Security Layer 3

Dessa forma, quando um usuário se conectar a WLAN guest, o mesmo terá que fazer uma autenticação em uma pagina Web antes de começar a navegar.

Por fim, vamos às configurações da interface de rádio, iniciando pelo padrão 802.11b/g/n.

Clique na guia WIRELESS > 802.11b/g/n > Network:

A checkbox 802.11b/g Network Status deve estar habilitada, bem como a 802.11g Support.

A configuração das taxas de transmissão (data rates) segundo Best Practices, deve ser feita conforme imagem abaixo:

802.11b/g/n Network Configuration

Para configuração do padrão 802.11a/n, clique na guia WIRELESS > 802.11a/n > Network e configure conforme imagem abaixo:

802.11a/n Network Configuration

Pronto, estas são as configurações básicas para colocar uma rede Wireless para operar.

O restante das configurações, visam melhorar o roaming e a detecção de buracos de cobertura e eu explicarei em detalhes em um post futuro.

Espero que isso seja suficiente para um bom começo. Atente para configuração da interface LAG. É importante que o switch esteja configurado de acordo e o WLC também, caso contrário um Bridging Loop pode ocorrer, pois o STP (Spanning-Tree Protocol) é desabilitado por default no WLC e NÃO deve ser habilitado.

Como este post já está muito grande, irei segmentá-lo! Em posts futuros mostrarei como configurar e aplicar Access Lists ao WLC de forma a limitar o acesso dos usuários guests, criar um perfil de lobby admin para criação de guest accounts e irei mostrar também algumas das funcionalidades da feature Auto-RF, na qual o WLC gerencia a potência de transmissão dos APs e o canal.

Atenciosamente,

Bartulihe

Anúncios
comentários
  1. Edmar Júnior disse:

    Boa Noite Marco,

    Venho enfrentando algumas dificuldades na configuração do meu WLC2106 com Aps WLCC2106

  2. Júnior disse:

    Edmar Júnior :
    Seu comentário está aguardando moderação.
    Boa Noite Marco,
    Venho enfrentando algumas dificuldades na configuração do meu WLC2106 com Aps WLCC2106

    Boa noite Marco,

    Venho enfrentando dificuldades na configuração do meu WLC com meus Aps, haveria uma forma de fazermos contato para um apoio mesmo que superficial? Fico no aguardo

  3. Mizael disse:

    Com certeza meu tópico favorito!

  4. Marcus disse:

    Bartulihe,

    Parabéns pelo blog, ajudou bastante em alguns laboratórios que fiz enquanto estudava para o CCNA Wireless.

    Não encontrei post referentes a essas configurações que você comentou.

    “O restante das configurações, visam melhorar o roaming e a detecção de buracos de cobertura e eu explicarei em detalhes em um post futuro.

    E irei mostrar também algumas das funcionalidades da feature Auto-RF, na qual o WLC gerencia a potência de transmissão dos APs e o canal.”

    Pretende criar um novo post com essas funcionalidades?
    Obrigado e parabéns novamente.

    • Bartulihe disse:

      E aí amigo!
      Cara é muito bom saber que o blog lhe ajudou nos estudos para o CCNA Wireles! Muito gratificante isso… E parabéns pela conquista!!!
      Sobre o post com as configurações referentes a melhorar o roaming e detecção de buracos de cobertura, a verdade é que eu esqueci de fazê-los rs mas que bom que você observou isso. São configurações bastante simples e fáceis, mas que fazem a total diferença no ambiente final.
      Em breve vou fazer um post com essas configurações. Você se inscreveu no blog?
      Se sim, vai receber a atualização por email assim que eu fizer esse post.
      Abraços
      Bartulihe

  5. Marcos disse:

    Simplesmente Show!!! Meus parabéns!!

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s