Configurando a LAG interface

Publicado: 15 de junho de 2011 em Wireless - WLC
Tags:, ,

LAG, ou Link Aggregation, é utilizado para transformar as duas interfaces do WLC 4402 ou quatro interfaces do WLC 4404 em uma única interface lógica, com o dobro de throughput e outras vantagens que serão listadas a seguir.

A interface LAG tb pode ser habilitada no WLC modelo 5508.

Nos controladores Wireless modelo WiSM e 3750G Integrated Wireless Lan Controller Switch, a interface LAG é habilitada por default, no entanto, na familia 440x e 550x, não.

LAG Interface

Uma outra vantagem em habilitar a LAG interface é que no WLC 4402, por exemplo, que suporta até 50 Access Points, apenas 48 são suportados sem utilizar a LAG interface.

Vantagens em habilitar a LAG port

  • As quatro portas do WLC 4404 (ou duas portas  do WLC 4402) são agregadas em um único link. Além disso, se um link “cair”, todo o tráfego é migrado para os demais links, ou seja, o mínimo necessário é 1 link ativo para o WLC repassar o tráfego dos clients wireless. Tal configuração também melhora a redundância do sistema.
  • Não é mais necessário configurar a primary e backup port para cada interface e é eliminada a necessidade de configurar diversas AP-manager interfaces.
  • Suporte ao valor máximo de APs, limitado pelo hardware, nos modelos de WLC da série 4400.

Habilitar a interface LAG é bastante simples, mas requer que se feita uma configuração no WLC e no Switch ao qual o WLC está conectado. Além disso, alguns cuidados devem ser tomados:

Cuidados necessários

  • As interfaces do WLC DEVEM ser conectadas ao mesmo switch. Este é um ponto muito importante, pois habilitar a interface LAG e ligar o WLC em switches diferentes pode fechar um looping Layer 2 na rede.
  • As interfaces do WLC podem estar conectadas a diferentes módulos do mesmo switch.
  • O load-balance recomendado é src-dst-ip (via CLI: port-channel load-balance src-dst-ip). Tal load balance força com que todos os fragmentos de um datagrama IP terminem em uma única porta do WLC. Não seguir tal recomendação pode resultar em problemas de associação dos Access Points.
  • Qualquer alteração na configuração do Link Aggregation requer que o WLC seja reiniciado.

As interfaces existentes são modificadas da seguinte forma:

  • A management interface é movida para LAG port
  • A static AP-manager é movida para LAG port
  • Todas as dynamic AP-manager interfaces são removidas
  • Todas as WLANs são disabilitadas e mapeadas para management interface (após o reboot é necessário mapear as WLANs para a VLAN apropriada)
  • Todas as dynamic interfaces com tag de VLAN são movidas para LAG port
  • Todas interfaces sem tag são removidas

Utilizarei a topologia abaixo como exemplo para mostrar qual a configuração necessária no WLC e no switch para habilitar a LAG interface.

Topologia conexão LAG Interface

  • Configuração no WLC

Acesse o WLC via Web Interface, clique em CONTROLLER > General:

Sete o parâmetro LAG Mode on next reboot para enable.

Configuração LAG WLC

Pronto! Esta é toda a configuração necessária no Wireless Lan Controller.

Vamos para o switch agora…

  • Exemplo de configuração no switch

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 30 mode on

!

interface GigabitEthernet3/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 30 mode on

!

interface port-channel 30

switchport trunk encapsulation dot1q

switchport mode trunk

————————————————————————————————-

Nota: Atribuindo interfaces do switch a um port-channel através do comando channel-group <ID> automaticamente cria a interface lógica port-chanel <ID>.

————————————————————————————————-

Pronto, a interface LAG está habilitade e devidamente configurada!

Abraços,

Bartulihe

Anúncios
comentários
  1. Vagner do Prado disse:

    Ola Marco excelente iniciativa, gostei bastante do seu site.
    Estou com um 4402 e 20 LAP 1242AG. Gostaria de saber como eu adiciono estes access point ao controlador. Quais interfaces do Controller preciso configurar para ele encontrar os APs? o que e preciso configurar nos APs, visto que a poucos comandos nestes modelo LAP. Gostaria muito do seu contato se possível.
    Grande Abraço.
    Vagner do Prado

    • wirelesscert disse:

      Olá Vagner!

      Agradeço muito os elogios.
      Se você me permitir, posso transformar a sua pergunta em um post?
      Dessa forma eu posso mostrar o passo-a-passo de como configurar um WLC do zero.

      Atenciosamente,

      Marco Bartulihe

  2. Vagner do Prado disse:

    Ola Marcos,
    Volto mais uma vez para questionar sobre um problema que venho tendo na implementação de um projeto Wireless.
    Estou instalando 20 AP LAP-1242AG, as mesmas vinheram com antenas 5.8 e 2.4, o fazer site survey, com antenas 5.8, tive baixa performance, porem com antenas 2.4 tive uma cobertura melhor, excelente sinal, cobrindo todo um andar. Pergunto, tem alguma configuração no Controlador pra acertar este ganho com a 5.8 ou e normal o baixo desempenho com este tipo de antena?

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s